[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] AMD IOMMU disabled - No Perdev Intremap

Sunday, October 6, 2013, 4:45:18 PM, you wrote:

> On 06/10/2013 15:38, Sander Eikelenboom wrote:
>> Sunday, October 6, 2013, 3:09:54 PM, you wrote:
>>> On 10/06/2013 02:58 PM, Andrew Cooper wrote:
>>>> On 06/10/2013 13:56, Ferdinand Nölscher wrote:
>>>>> Hi Sander,
>>>>> Thanks for your reply.
>>>>> On 10/06/2013 02:10 PM, Sander Eikelenboom wrote:
>>>>>> Sunday, October 6, 2013, 1:36:33 PM, you wrote:
>>>>>>> Hi!
>>>>>>>> From other people posting to this list, I know that there has
>>>>>>>> been a
>>>>>>> bug related to the issue described in Xen Security Advisory 36
>>>>>>> that disables iommu for some AMD users like me.
>>>>>> What motherboard do you have ?
>>>>> I have an ASUS M5A99X EVO Rev 1.01
>>>>>> It depends if it's the north or southbridge ioapic but try using
>>>>>> the new xen boot parameter: (add it to the xen.gz line in grub)
>>>>>> ivrs_ioapic[0]=00:14.0
>>>>>> or
>>>>>> ivrs_ioapic[0]=00:00.1
>>>>> I tried both, it still fails to enable i/o virtualisation.
>>>> Can you post a full xl dmesg, booting with iommu=debug,verbose as well?
>>>> ~Andrew
>> Ah it seems i got the id's mixed up :-)
>> ivrs_ioapic[9]=00:00.1 ivrs_ioapic[10]=00:14.0
>> Should do it i guess .. or should the ioapic handle be in hex .. (then the 
>> last should be ivrs_ioapic[a]=00:14.0 )
>> --
>> Sander

> parse_ivrs_ioapic uses simple_strtoul(..., 0), so decimal or 0xa is
> fine, but 'a' on its own wont be.

> Seeing as I clearly don't understand how this fix is working, do you
> mind explaining (as you seem to have worked out the problem) ?

Bios provided tables are a mess .. regarding to iommu's it seems to be a double 
And motherboard manufacturers seem to be quite incapable to provide sane tables 
for years now, and it doesn't have any kind of priority.
(ok that little rant is out :-p )

But on (current / consumer) AMD systems, the mapping always seems to be the 
same ioapic northbridge to 00:00.1 and southbridge to 00:14.0.
So if you know the ioapic handle's from the xl dmesg output, you can easily 
determine the needed override.

It's perhaps a bit unfortunate that the error without iommu=debug,verbose 
doesn't show the handle but only the id:

(XEN) IVHD Error: Invalid IO-APIC 0
(XEN) AMD-Vi: Error initialization
(XEN) I/O virtualisation disabled

And it should probably be something for the next document day to have some 
documentation for it on the iommu part of the xen-wiki.


> ~Andrew

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.