[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 02/23] PVH xen: turn gdb_frames/gdt_ents into union.

On Sat, Jul 20, 2013 at 2:44 AM, Mukesh Rathor <mukesh.rathor@xxxxxxxxxx> wrote:
> Changes in V2:
>   Changes in V3:
>     - Rename union to 'gdt' and rename field names.
>   Change in V9:
>    - Update __XEN_LATEST_INTERFACE_VERSION__ to 0x00040400 for compat.
> Signed-off-by: Mukesh Rathor <mukesh.rathor@xxxxxxxxxx>
> Reviewed-by: Jan Beulich <jbeulich@xxxxxxxx>

One thing that's missing here is a description of *why* this change is
being made.  Seeing that it's introducing a union isn't too difficult;
harder is figuring out why that's necessary.

Presumably this is to more closely reflect how an HVM guest's GDT is
stored -- i.e., in the guest's memory and checked by the hardware on
use, rather than in Xen's memory, and checked by Xen on assignment?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.