[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v8 1/2] xen: introduce vcpu_block and vcpu_block_enable_events

>>> On 22.04.13 at 22:00, Keir Fraser <keir.xen@xxxxxxxxx> wrote:
> On 22/04/2013 18:42, "Stefano Stabellini" <stefano.stabellini@xxxxxxxxxxxxx> 
> wrote:
>> Rename do_block to vcpu_block.
>> Move the call to local_event_delivery_enable out of vcpu_block, to a new
>> function called vcpu_block_enable_events.
>> Use vcpu_block_enable_events instead of do_block throughout in
>> schedule.c
> While you're there, could you make both vcpu_block variants return void?

And I don't see why vcpu_block_enable_events() needs to
become non-static...


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.