[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] FastModels Xen Crash - Guest data abort: Translation fault at level 2


Using the latest Xen staging ( git://xenbits.xen.org/xen.git - staging ) and the lastest kernel for dom0 ( git://github.com/torvalds/linux.git - master ) Xen crashes starting dom0. I tried 3 approaches:

1. mmc filesystem
          xen,dom0-bootargs = "earlyprintk=xenboot console=ttyAMA0 mem=2048M root=/dev/mmcblk0 rw ip=dhcp"
          crashlog attached "xen_crash_1_mmc"
2. nfs filesystem
          xen,dom0-bootargs = "earlyprintk=xenboot console=ttyAMA1 rw root=/dev/nfs nfsroot= ip=dhcp";
          crashlog attached "xen_crash_2_nfs"
3. ramdisk - this works!

All of these work without Xen, when just booting linux on FastModels. Is this something I did wrong in my setup or have other people had similar issues? I was also wondering if I could get a link to a filesystem that definitely works. I tried several already but it seems they are not the issue since they boot fine without xen on the same model with the same kernel.


Attachment: xen_crash_1_mmc
Description: Binary data

Attachment: xen_crash_2_nfs
Description: Binary data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.