[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] PCI USB Passthrough on Kernel 3.5 and 3.6 not working (HVM or PVM)

Hi Xenners,

I have tried to upgrade to kernel 3.5 and experienced the USB/PCI
passthrough problem.  This has not been "fixed" in 3.6 either.  I do not
know if this is qemu, xen or kernel related.

I am using Xen 4.2 final and Xen 4.3-unstable to test.

DomU is Windows 7 64 bit or Linux Fedora 17.  In Windows, I get the
little yellow triangle with Code 10 (I know this means nothing...
really).  In linux, the PCI device is recognised, but a few seconds
later disabled due to a "fatal error", no more details than that in

Dom0 retains full control over the USB controller (this is not the case
when passthrough works, xl switches between Dom0 and DomU depending on
who claims the device).  

In both Windows and Linux (lspci), the device is "seen" but cannot be

In Dom0, the device is assigned to the guest (xl pci-list show that it
is assigned and has a valid guest PCI ID).

Xen logs are normal, devices get assigned as if they were working with a
kernel 3.3.4 Dom0 - no errors according to xen logs or xl dmesg.

VGA PCI passthrough works 100%.

I tried also with device model qemu-xen, but then passthrough doesn't
work at all (no VGA either), even with upstream QEMU from git.

Please tell me if I'm missing something obvious or if I can provide more
information for troubleshooting!

Kind regards,

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.