[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.0.4, kernel 3.5.0 HVM crash and kernel BUG


Tried boogin with vif-parameters commented out, result is the same:

Error: Device 768 (vbd) could not be connected. Hotplug scripts not working.

But what is more troubling with these issues I'm having is the fact that this "hotpluf scripts not working" came out of nowhere. I was able to boot my Windows domU just fine earlier with only problem being that the VNC output was just black screen after Windows installer had started. Then I tried to create a Linux HVM (debian squeeze) and then I got that "Hotplug scripts not working" error. And after trying to start Windows domU again it says that same "Hotplug scripts not working" error.

If I reboot the machine and start my Windows domU it will start again just fine, but the VNC output is just black screen. Then again, if I start the Linux HVM domU I will again get that "Hotplug scripts not working" error and then the Windows domU wont start either again and tells the same "Hotplug scripts not working" error.

So this is pretty confusing and troubling indeed.

I will reboot the machine later and put those boot parameters that Pasi mentioned.

- Valtteri

2012/10/2 Konrad Rzeszutek Wilk <konrad@xxxxxxxxxx>
On Tue, Oct 2, 2012 at 9:01 AM, Valtteri Kiviniemi
<kiviniemi.valtteri@xxxxxxxxx> wrote:
> Hi,
> I already tried 3.2, 3.5, 3.5.0, 3.6.0-rc7 and 3.6.0, same problem all of
> those. My dom0 config is the same config that I'am using on other server
> where HVM is working, so I dont think that it is a config problem. I have
> triple checked everything and all should be ok. dom0 dmesg shows the same
> crash that I have previously posted here. /var/log/xen/ does not contain any
> specific errors.
> Could this be some kind of broblem with my motherboard bios being buggy or
> CPU not supported? I'm using the new intel Ivy Bridge processor which has
> integrated GPU, but that should not probably cause these kind of problems.
> Or maybe some ACPI problem? xm dmesg is showing some notices about ACPI. Is
> there any ACPI kernel parameters that I should try booting? This has to be
> somekind of problem with my hardware, or then maybe it could be a kernel
> problem too. I just really cant figure this out myself, I have tried
> everything.
> Lets take a quick summary of what has been tested, what hardware I'm using
> etc.
> Xen-versions tested: 4.2.0, 4.0.4
> Kernel-versions tested: 3.2.0, 3.5.0, 3.5.4, 3.6.0-rc7, 3.6.0
> Host OS: Debian testing/wheezy, udev version 175-7, 2.13-35, python version
> 2.7.3~rc2-2.1
> Hardware:
> CPU: Intel Core i7-3770 3.4GHz
> MB: Intel DQ77MK (latest bios updated)
> Memory: 32GB (4 x 8GB DDR3-1600MHz)
> All relevant log files and configs:
> dom0 dmesg: http://nago.fi/dmesg.txt
> qemu-dm log: http://nago.fi/qemu-dm.txt
> xm dmesg log: http://nago.fi/xm-dmesg.txt
> domU config: http://nago.fi/domu-config.txt
> dom0 kernel config: http://nago.fi/dom0-config.txt
> I have also tried playing with every setting on that domU that I can think
> of and tried different configs etc.

This is troubling. You seem to trigger the QEMU closing the tunX (your
Windows's guest network interface) which then crashes somehow.
Just to make sure that this is the case - can you try launching your
guest without network and seeing what happens?

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.