[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 5/6] libxl: introduce libxl__alloc_vdev

On Tue, 3 Apr 2012, Ian Jackson wrote:
> Stefano Stabellini writes ("Re: [Xen-devel] [PATCH 5/6] libxl: introduce 
> libxl__alloc_vdev"):
> > I don't feel that strongly about this, but given that the naming scheme
> > used in the guest is actually arbitrary at the moment (as in not document
> > or well defined anywhere), I would start the dynamic space before the
> > 26th device: I have the feeling that after "xvdz" the behavior is going
> > to be even less "defined". I suggest "xvdm" as a starting point.
> That's fine, if the starting point is configurable.

I don't think it is worth adding one more option for something like
this: nobody should be using this option anyway. I am still unconvinced
there is a valid use case for this.
Can't we just agree on a starting point, any really?

> > > However, that does not mean that the guest should not document its
> > > naming conventions.  Perhaps this needs to be clarified in the
> > > document.
> > 
> > Right, but unless I am missing something there isn't such a thing at the
> > moment, at least in Linux.
> > 
> > I'll try to come up with a linux devid to vdev function true to the
> > original.
> That would be good.  If you felt like documenting the Linux behaviour
> properly that would be good.  The section "Notes on Linux as a guest"
> in docs/misc/vbd-interface.text.

the best place for this would be in the Linux Documentation

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.