[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] linux-3.4-rc0 XENBUS: Device with no driver: device/vbd/51713

Hi Konrad,

I just tried linux-3.4-rc0 (linus his tree, last commit 
f52b69f86e27903d6896ed5fa7cd280fec8de532) with 3 additional branches from your 
tree pulled on top of that:

branch stable/for-ingo-3.4.v2     (required for dom0 to boot)
branch stable/for-jens-3.4
branch stable/for-jens-3.4-bugfixes

Hypervisor is xen-4.1.3-rc1-pre
linux 3.3 vanilla works fine

Booting dom0 goes fine, but PV-guests don't work, it seems something goed wrong 
with registrering the devices.
Which is kind of strange because i compiled the kernel with the same .config 
(all xen stuff is compiled in, no modules).

Nothing else is changed in between, I also tried reverting some of the 
xen-front patches but all to no avail .. do you have any suggestions ?

.config is attachted

This is on the guest console:

[    0.219507] TCP: cubic registered
[    0.219513] NET: Registered protocol family 17
[    0.219530] Bridge firewalling registered
[    0.219536] Ebtables v2.0 registered
[    0.219550] Registering the dns_resolver key type
[    0.219736] registered taskstats version 1
[    0.219748] XENBUS: Device with no driver: device/vbd/51713
[    0.219752] XENBUS: Device with no driver: device/vbd/51714
[    0.219757] XENBUS: Device with no driver: device/vif/0
[    0.219789]   Magic number: 1:252:3141
[    0.219840] console [netcon0] enabled
[    0.219844] netconsole: network logging started
[    0.219848] saa7134 ALSA driver for DMA sound loaded
[    0.219852] saa7134 ALSA: no saa7134 cards found
[    0.220222] Freeing unused kernel memory: 716k freed
Loading, please wait...
mount: mounting none on /dev failed: No such device
W: devtmpfs not available, falling back to tmpfs for /dev
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ...
Begin: Waiting for root file system ... done.
Gave up waiting for root device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  /dev/xvda2 does not exist.  Dropping to a shell!

Attachment: config
Description: Binary data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.