[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Crash/trace when starting oprofile

Hello Xen developers, 

I sent a similar message to xen-users about a week ago, did not obtain any response and only now realized that I should have sent this here instead (http://xenoprof.sourceforge.net/ says to write to this list). Apologies if you see this message twice.

I am trying to run oprofile in my dom0, but get a crash (displayed as a call trace in dmesg) as soon as I run opcontrol --start.
I assume this is a Xen problem because the first line reads: 

WARNING: at /build/buildd/linux-3.0.0/arch/x86/xen/enlighten.c:732 xen_apic_write+0x1a/0x20()

The corresponding full dmesg output is available at the following pastebin: http://pastebin.com/mRuqkPSV
Note that the crash doesn't really crash Xen, it's just a call trace that is output, everything but oprofile seems to be working.

My setup:
Xen version is 4.1.1, booting a x86_64 3.0.0-17 dom0 kernel. Oprofile is version 0.9.6 and supports the --xen option. Those are the latest packages available for ubuntu oneiric for both kernel and Xen. I chose to install from ubuntu packages for convenience (not having to build Xen from scratch, etc..)
CPU is an AMD Opteron Processor 6168.

How to reproduce:
Right before I run opcontrol --start, I do: opcontrol --setup --vmlinux=/usr/lib/debug/boot/vmlinux-vmlinux-3.0.0-17-server
I tried with --no-vmlinux, same result. The trace appears when I run opcontrol --start.

I also tried booting off the aforementioned kernel directly as well, with no hypervisor involved at all, and did not get anycall traces or crashes (obviously, since Xen is no longer involved, but I wanted to make sure there isn't something else going on).

Googling didn't help much, I just found references to other pastebins with similar traces, but could not find any post referencing those pastes. 

I am not sure if this issue is known or has even been fixed in development versions. 
(I tried installing the development version from the master branch, but couldn't get it to run since "make install" would not install user-level executables; tried installing manually from tools/python but got lots of errors I have not been able to solve -- but that is a separate issue).

I am not sure about what is going on and how to proceed. I would appreciate any suggestions to solve this issue. I suspect this is a bug in Xen.

Thank you in advance,

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.