[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Problems with stubdoms, and xl

On Fri February 17 2012, 3:14:39 PM, jim burns wrote:

> > 2) I'm having a strange problem right after I get a xen update from > > rawhide: stubdoms stop working for a day after wards. It happened with > > fedora xen 4.1.2-7 and -8. The next time it happens, I'll look at > > whether something in /var/lib/xen* changed. > > Stop working for a day and then magically starts working? Or stops > working for a day until the next update?   As it turns out, both, the two times it happened to me. Stubdoms stop working until the next yum update, but nothing installed the next day has any relationship to xen or a kernel. Whether or not it would have worked 1/2 hour before the yum update is not something I have had an opportunity to explore yet. Of course, a yum update is frequently accompanied by a systemd restart, which could have an effect.

Well, at least I got this one figured out. It wasn't the next day's yum update that fixes things - it was another cron daily job: prelink. I just got a xen update (fedora rawhide), I stopped my stubdom, tried to start it again, and it failed. Then I ran the prelink job again (it normally executes before yum, which I had changed) - and lo and behold, my stubdom started!


Xen commands are the only commands that I haven't been able to execute w/o prelink-ing, and only this one function, so I didn't immediately suspect that running yum after prelink would be a problem. Live and learn!

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.