[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] r: (1, 'Internal error', 'panic: xc_dom_core.c:273: xc_dom_do_gunzip: inflate failed (rc=-3)').. only on Intel hardware and only under 32-bit dom0

On Tue, Feb 21, 2012 at 08:59:35AM +0000, Ian Campbell wrote:
> On Mon, 2012-02-20 at 18:32 +0000, Konrad Rzeszutek Wilk wrote:
> [...]
> > sh-4.1# xm create /mnt/lab/latest/test.xm 
> > Using config file "/mnt/lab/latest/test.xm".
> > Error: (1, 'Internal error', 'panic: xc_dom_core.c:273:
> > xc_dom_do_gunzip: inflate failed (rc=-3)')
> -3 == ESRCH? Seems unlikely...
> Aha, in this context it is the return value of inflate() and therefore
> it is Z_DATA_ERROR.
> > And only on Intel.. and only if it is a 32-bit dom0. If I do the same
> > test with a 64-bit dom0 I do not see this problem.
> Different decompression libraries in your root filesystems perhaps? Can

Hm, not sure. So I tried the code on the root filesystem and it worked
fine and gave an binary image that was the same as on another machine.

But I wonder if the libxl use the shared library or compile it in. Perhaps
there is some weird library version mismatch. Will double-check.

> you decompress the bzImage by hand? (perhaps using the attached bzeplode
> to extract the compressed data payload)
> Does it work with xl?

> > Any thoughts of what it might be or what I should try out? My thought
> > was to swap out the hypervisor (use a Xen 4.0) or unstable and see if
> > I get the same result.
> It is unlikely to be the hypervisor, more likely to be one of the
> userspace components of the toolstack.

I think you are right..

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.