[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] arch linux xen 4.2 no network

On Sun, 2012-02-19 at 22:12 +0000, jacek burghardt wrote:
> I just created arch linux xen 4.2 unstable package so it compiled fine
> and installs fine. When I run xl create it starts vm. I have vif
> devices created but they don't attach to bridget that are created on
> startup . I have xenbr0 and xenbr1 created. 

Do you have the udev rules installed in the right place?

> If I run this I get vifi attached ro bridge. Is this xl issue or
> python. 
> # export vif=vif1.0
> # export XENBUS_PATH=/local/domain/0/backend/vif/1/0
> (found with `xl network-list`)
> # export bridge=br0

This is neither of the bridge names which you stated above.

If your bridge is called "br0" then you probably need "bridge=br0" in
your vif configuration line or to set "defaultbridge"
in /etc/xen/xl.conf.

> # /etc/xen/scripts/vif-bridge add
> # /etc/xen/scripts/vif-bridge online
> It seems that xen has to be compileg with python 2.7 . I wonder if
> this well known bug are there any patches.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.