[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 1 of 2] libxl_pci: rename is_assigned to is_pcidev_in_array

Doug Magee writes ("[PATCH 1 of 2] libxl_pci: rename is_assigned to 
> All this function does is check to see if a device is in an array of pcidevs 
> passed by the caller.  The function name can be misleading if ever used to 
> check against a list of devices other than those assigned to a domain.

This is a good change and I have committed it, but I think it would be
good to change the name of the formal parameter to is_pcidev_in_array,
too, to "array" or "devices" or "haystack" or something.  And a
corresponding change to num_assigned.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.