[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] problems I encountered using xen-4.1-testing and xen-unstable

On Thu, Jan 05, 2012 at 08:05:26AM +0000, Ian Campbell wrote:
> On Wed, 2012-01-04 at 23:35 +0000, Konrad Rzeszutek Wilk wrote:
> > On Wed, Jan 04, 2012 at 10:07:29PM +0000, Kay, Allen M wrote:
> > > I'm encountering following problems while using the latest 
> > > xen-4.1-testing and xen-unstable with the latest Linux 3.2 kernel:
> > > 
> > > 
> > > 1)      Xen-4.1-testing: dom0 only sees ~2.6GB on a 4GB system, using 
> > > "cat /proc/meminfo".  This is without dom_mem boot parameter and with 
> > > 64-bit Xen and dom0 Linux.  Native Linux reports correct memory size.
> > 
> > Huh. You are right. Hadn't noticed that before since I was using dom0_mem.
> > 
> > Ian, David: any ideas?
> Nope. It would be nice to see some logs (xen+dom0 and native) though.

I tried this last night and it seems that this problem has existed in 3.0 and 
in 3.1 as well.
So not a regression but rather something we had never fixed. Interstingly 
enough you can experience
the same problem with 8GB - you end up having 6GB in dom0. Naturally you can 
balloon up (hadn't tried
to do it under 4GB with 2.68GB but it looks like you can certainly do it).

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.