[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] USB virt 2.6 split driver patch series
I had a look at xenidc code, and found some code like this: -- static void xenidc_endpoint_destroy_1(xenidc_callback * callback) { trace(); { xenidc_endpoint_callback *endpoint_callback = container_of(callback, xenidc_endpoint_callback, callback); endpoint_callback->destroyed = 1; xenidc_work_wake_up(); } } -- Why name it *destroy_1? it is a common practice to name a local function with _ or __ as prefix. So for example xenidc_endpoint_destroy_1() should be named _xenidc_endpoint_destroy_1() or __xenidc_endpoint_destroy_1() Hieu _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-devel
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |