[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] Rolling Pool Upgrade Problem (HELP!)

  • To: xen-api@xxxxxxxxxxxxx
  • From: Felipe Fidelix <eu@xxxxxxxxxxxxxxxxx>
  • Date: Sat, 23 Jun 2012 01:33:59 -0300
  • Delivery-date: Sat, 23 Jun 2012 04:34:18 +0000
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>

Helo all. I get an obscure error when trying to upgrade XenServer to 6.0 to 6.0.2. Using the "Rolling Pool" upgrade.

This is the error: http://i.imgur.com/in54C.png

More details (/var/log/messages) http://paste2.org/p/2058242
Here is the exact log of /var/log/xensource.log, from the exact time of the upgrade: http://paste2.org/p/2058264
This is what shows up on xencenter log: http://paste2.org/p/2058179

All the VMs are shut down. I tried restarting the server. No luck.

I did see this thread: http://forums.citrix.com/thread.jspa?threadID=294610
But the error that shows up on the thread author's log
> Oct 1 05:47:01 xssp2 fe: 11155 (/etc/xapiâ.d/plugins/pârepare_host_â upgrade.py <methodâCall><âmethodName&gât;main</mâet...) exitted with code 0

Does NOT show up on my log. So I think it's a different problem.
I tried editing the file /etc/xapi.âd/plugins/prâepare_host_uâpgrade.py
And setting the logging level to DEBUG:
logger.logâToSyslog(levâel = logging.DEâBUG)

But the log is still useless. I deleted the .pyc file, rebooted, log is still useless. I didn't try the attached script because it is from 2011, 6.0, and I thought it might generate other problems.

Suggestions, please?

PS. I can't upgrade using the CD because I have no physical access to the machine. This is a dedicated server, all remote. I don't have ILO or any similar stuff (only KVM, if I pay 90 euros).

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.