[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] Xmlrpc response missing vif data

On 23/05/12 11:38, Little Vaerivatnet wrote:
Hi all,
    I'm unable to resolve following problem:
- Remus network buffering doesn't work. It seems to be because of no vif
is reported by the function server.xend.domain on line 29 of
packages/xen/remus/vm.py (seen using pdb) :
  27    if domid:
  28       try:
  29          self.dominfo = server.xend.domain(domid, 'all')


- xl list -l fsb.t.org <http://fsb.t.org> (see below) shows vif data
- the VM is connected to the network during the boot (with a static IP
via a bridge) without any problem
- live migration between two xen servers works well, but with some
packet loss
- the problem persists regardless xen or kernel dom0 and domU version, I
tried xen 4.1.2, 4.2 unstable, jeremy's kernel (a described on
http://remusha.wikidot.com/ page) and ubuntu pae kernels
- no disk replication for the moment (for the sake of simplicity)
- some more info follows.

I tried to follow the processing, but if I'm right the request is
processed by the xenstored and I don't know ocaml...

I don't think you would want to bother reading the xenstored source code, but instead would want to inspect the xenstore using xenstore-ls, xenstore-list, etc.

Should I try xapi? Is Remus compatible with xapi?

Xapi does not understand Remus, so no, I wouldn't recommend trying xapi here.

Thanks a lot for any ideas.

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.