[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] device disappeared from xenstore



I've attached a snippet from my syslog.


My current status is I reinstalled again and this time tried to install an ubuntu vm using the instructions here (http://wiki.xen.org/wiki/Installing_Linux_on_Kronos)


I get the same error:

the device disappeared from xenstore (frontend (domid=1 | kind=vbd | devid=51712); backend (domid=0 | kind=vbd | devid=51712)) ]


In the syslog you'll see some other errors:

May 2 13:27:51 kronos xapi: [ info|kronos|0 thread_zero||watchdog] (Re)starting xapi...
May 2 13:27:51 kronos xapi: [ warn|kronos|0 thread_zero|server_init D:2539aa6797cb|startup] task [Checking control domain] exception: Xenctrl.Error("Unable to open XC interface")
May 2 13:27:51 kronos xapi: [error|kronos|0 thread_zero||xapi] Caught exception at toplevel: 'Xenctrl.Error("Unable to open XC interface")'
May 2 13:27:51 kronos xcp-fe: 2810 (/usr/sbin/xapi -nowatchdog -writereadyfile /var/run/xapi_startup.cookie -writ...) exitted with code 2


I always get errors on startup.  My process has been to log in and run /usr/lib/xcp/bin/xe-toolstack-restart which seems to get all of the services into a functional state.


I'm trying to persevere but I've been at this for a couple of weeks now and nothing has worked.  I don't doubt it's somehow my lack of understanding but I'm not sure where to turn.  Do you think my PC could somehow just not be compatible?  That sounds crazy to me but I'm grasping at straws.  Or do some people have better luck with Ubuntu than Debian?






On May 2, 2012 at 5:49 AM Jonathan Ludlam <Jonathan.Ludlam@xxxxxxxxxxxxx> wrote:

No, that should be fine - I run the 64 bit version on my laptop, and it seems to work nicely. The 32 bit version is more thoroughly tested, that's all. You should certainly be able to start vms :-)

On 1 May 2012, at 22:22, David Hout wrote:

Perhaps I should have asked this earlier but ...


I am trying to install kronos on a 64-bit debian installation on an amd64 box.  Should I be starting with the 32 bit debian iso instead?  Does that matter?




On May 1, 2012 at 1:13 PM Jonathan Ludlam < Jonathan.Ludlam@xxxxxxxxxxxxx> wrote:

Those alarming 'http_critical' messages are all benign. Unfortunately there's nothing to indicate the cause of your problems in that log. Anything in /var/log/syslog?

On 1 May 2012, at 17:46, David Hout wrote:



I see a lot of "[http_critical] Premature termination of connection!" messages.  Do you know if those are normal or perhaps that is a clue?


I attached a log snippet in case you are curious.







On May 1, 2012 at 10:41 AM Jonathan Ludlam < Jonathan.Ludlam@xxxxxxxxxxxxx> wrote:

Hmm. Have a look through /var/log/xcp-xapi.log and see if there's anything interesting in there?

On 1 May 2012, at 14:24, David Hout wrote:

Thanks Jon - I ran that and xend is not running



On May 1, 2012 at 8:50 AM Jonathan Ludlam < Jonathan.Ludlam@xxxxxxxxxxxxx> wrote:

Hi Dave,
Have you disabled xend? Run:
ps auxw | grep xend
and see if you get anything. 

On 1 May 2012, at 13:44, David Hout wrote:



I'm getting closer with my Kronos on Debian configuration.


I'm issuing a series of xe commands to launch a vm and it's failing with a "device disappeared from xenstore" error.  Can anybody provide guidance?






Here is the sequence of CLI commands I'm running followed by the error message:


TEMPLATE=`xe template-list name-label=âDebian Squeeze 6.0 (32-bit)â --minimal
VM=`xe vm-install template=$TEMPLATE new-name-label=debian`
NETWORK=`xe network-list bridge=xenbr0 --minimal`
VIF=`xe vif-create vm-uuid=$VM network-uuid=$NETWORK device=0`
xe vm-param-set uuid=$VM other-config:install-repository=http://ftp.uk.debian.org/debian
xe vm-memory-limits-set static-min=256MiB static-max=256MiB dynamic-min=256MiB dynamic-max=256MiB vm=$VM
xe vm-start uuid=$VM

This runs for a few seconds and comes back with an error:
The server failed to handle your request, due to an internal error.  The given message may give details useful for debugging the problem.
message:  the device disappeared from xenstore (frontend (domid=1 | kind=vbd | debid=51712); backend (domid=0 | kind=vbd | devid=51712))





Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.