[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] [SPAM] DEFAULT_SR_NOT_FOUND when importing a VM

  • To: xen-api@xxxxxxxxxxxxxxxxxxx
  • From: "Jean-Francois Couture" <jfcouture@xxxxxxxxxxxxxx>
  • Date: Wed, 02 Mar 2011 11:35:57 -0700
  • Delivery-date: Wed, 02 Mar 2011 10:37:19 -0800
  • Importance: Low
  • List-id: Discussion of API issues surrounding Xen <xen-api.lists.xensource.com>

in xenServer 5.6,
I'm trying to import a XVA file via command line using curl.
I tried the example in the sdk document telling:
curl -T <exportfile> http://root:foo@myxenserver2/import?sr_uuid=<uuid_of_sr>
my exact line :  curl -k -T 12c38b19-c528-aa1c-5a4c-4112875c02f9.xva https://root:<password>@
on that example, the server is the pool master but the SR is on another machine.
I tried with the SR's server IP also.
using my credentials and copy/paste the UUID of the target SR (from xenCenter).
I also checked the UUID using "xe sr-list type=lvm" to be sure.
I even tried the OpaqueRef: reference to that SR
but its not working.
the error I get is : <html><body><h1>Internal Server Error</h1>DEFAULT_SR_NOT_FOUND: [ OpaqueRef:NULL ]</body></html>
My config is 3 xenservers 5.6 (not fp1) in a pool each with local storage.
On the otherhand, exporting a VM with curl works great.
Could someone shine some light on my problem ?
Jeff C.
xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.